WordPress禁用特定插件的更新提示

22年04月16日

方法一:
Wordpress插件能一键更新是件好事,而有不好免费好用的插件。可是有些插件为了追求更大的商业利益,在更新之后,经过改版,原来免费的功能不能使用了,也没有以前版本那么方便了,于是想让特定的Wordpress插件停留在某个版本。例如Google Analytics Dashboard for WP (GADWP)插件,5.3.10版本更新到之后的版本,样式改了许多,但是很多免费的功能不能用了。

于是就在网上找到以下这段PHP代码来禁止某个插件获取更新信息,也不会在Wordpress后台提示更新。你只需要把下面的代码修改后加入你主题函数文件里面就可以了,修改部分为斜体加粗字体的字段,将其替换为自己想禁卡更新的插件位置和加载文件的名称。添加代码到Wordpress博客当前使用的主题或子主题文件夹下functions.php文件里面:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
//屏蔽插件更新通知

function wcr_remove_update_notifications($value) {
// 要屏蔽的插件位置 (在wp-content/plugins文件夹下)
$plugins = array(
'google-analytics-dashboard-for-wp/gadwp.php'
);

foreach ($plugins as $key => $plugin) {
if (empty($value->response[$plugin])) {
continue;
}

unset($value->response[$plugin]);
}

return $value;
}

add_filter('site_transient_update_plugins', 'wcr_remove_update_notifications');

这样就禁用了Google Analytics Dashboard for WP (GADWP)插件的更新和更新提示的显示。
方法二:
修改插件版本号到最新

相关文章

给句点评吧!
loading